a network service error occured

Hello, I am pretty new with zimbra.

zimbra 8 is my first zimbra. but... it has driven me crazy these two weeks.

I accidentally change all the ownership of zimbra file into zimbra user and group. so I tried to overwrite and re-install the zimbra without change the db and mailbox. unfortunately it driven me into more complex error that I could not understand.

Here is the status of my zimbra server

Release 8.0.7_GA_6021.RHEL6_64_20140408123911 RHEL6_64 FOSS edition.

I am trying to run zmprov

ERROR: service.PROXY_ERROR (error while proxying request to target server: HTTP/1.1 404 Not Found)

All services are running (zmcontrol status)

       antispam                Running

       antivirus               Running

       ldap                    Running

       logger                  Running

       mailbox                 Running

       mta                     Running

       opendkim                Running

       snmp                    Running

       spell                   Running

       stats                   Running

       zmconfigd               Running

Mailbox log

       at org.eclipse.jetty.http.HttpParser.parseAvailable(HttpParser.java:235)

       at org.eclipse.jetty.server.AsyncHttpConnection.handle(AsyncHttpConnection.java:82)

       at org.eclipse.jetty.io.nio.SslConnection.handle(SslConnection.java:196)

       at org.eclipse.jetty.io.nio.SelectChannelEndPoint.handle(SelectChannelEndPoint.java:668)

       at org.eclipse.jetty.io.nio.SelectChannelEndPoint$1.run(SelectChannelEndPoint.java:52)

       at org.eclipse.jetty.util.thread.QueuedThreadPool.runJob(QueuedThreadPool.java:608)

       at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(QueuedThreadPool.java:543)

       at java.lang.Thread.run(Thread.java:744)

Caused by: com.zimbra.common.service.ServiceException: error while proxying request to target server: HTTP/1.1 404 Not Found

ExceptionId:qtp662845511-168:172.31.20.51/:1399360523644:46eeb2b02aeae929

Code:service.PROXY_ERROR Arg:(url, STR, "http://localhost/service/soap/AuthRequest")

       at com.zimbra.common.service.ServiceException.PROXY_ERROR(ServiceException.java:327)

       at com.zimbra.common.soap.SoapHttpTransport.invoke(SoapHttpTransport.java:242)

       at com.zimbra.common.soap.SoapHttpTransport.invoke(SoapHttpTransport.java:167)

       at com.zimbra.common.soap.SoapTransport.invoke(SoapTransport.java:386)

       at com.zimbra.client.ZMailbox.invoke(ZMailbox.java:622)

access log

127.0.0.1 -  -  [06/May/2014:07:34:28 +0000] "POST /service/admin/soap/AuthRequest HTTP/1.1" 404 1395 "-" "zmprov 8.0.7_GA_6021" 1

Any idea what cause this error occur and what should I do to fix this.

I will appreciate every responses you give. thank you.

Related