Default Forum Notification Settings

We have a group that the Registered User role is a member of.  We have noticed that when new users are added to that role, they automatically are set to receive the real-time notifications for forum posts.  We don't want this to happen, but I don't see a setting on the forum or the group to turn that off.  

How do we change this default behavior?

  • Hi Kris,

    You may want to disable new group members being auto-subscribed to forums... A similar thread with fix can be found here: telligent.com/.../1359547.aspx

  • In reply to Steven Heffner:

    Steven Heffner

    Hi Kris,

    You may want to disable new group members being auto-subscribed to forums... A similar thread with fix can be found here: telligent.com/.../1359547.aspx

    As I reported in that thread, the suggested fix has been tested and found NOT to work with 7.6. We need another solution.

  • Agreed.  I would like to see this resolved.  Hopefully they can get something together for a patch or future release.
     
    From: cnsanford [mailto:bounce-cnsanford@communities.telligent.com]
    Sent: Monday, January 13, 2014 12:38 PM
    To: bugsandissues@communities.telligent.com
    Subject: RE: [Bugs and Issues - Telligent Community] Default Forum Notification Settings
     
    Steven Heffner
    Hi Kris,
    You may want to disable new group members being auto-subscribed to forums... A similar thread with fix can be found here: telligent.com/.../1359547.aspx
    As I reported in that thread, the suggested fix has been tested and found NOT to work with 7.6. We need another solution.
  • In reply to Kris Torres:

    Hi, I am under the impression that in 7.5/7.6 the plugin api was extended to also allow event based plugins (a replacement for CSModules) and therefore am wondering if the GroupForumAutoSubscriptionModule CSModule has been upgraded in 7.6 to instead be a plugin. If this is the case I would guess it could be disabled by looking at the plugin configuration under the control panel. I may be wrong though and some or all of the out of the box modules may not have been upgraded to plugins yet in 7.6 (I don't have a copy of 7.6 running to check this at the moment).

    If this isn't the case then another reason this may not be working could be due to how this is being implemented. Are you doing this in an communityserver_overide.config file or directly in the communityserver.config file? Did you touch the web.config/recycle the websites app pool after you made the change?

    Hope this helps.

    Adam

  • In reply to Adam Seabridge:

    Adam, that is a good thought; however in 7.6 the GroupForumAutoSubscriptionModule is still a CSModule. In our upcoming 8.0 release all internal CSModules have been converted to plugins.

    The overrides file is still the recommended way to disable CSModules; and as Adam says, you'll need to make sure you recycle your app pool after any config file changes.

    We're looking into the issue internally and hope to have some more information for you all shortly.

Related