• Not Answered

REST GET Request with Multiple Parameters

I am running Enterprise 3.1 and running a REST endpoint request for activities. It is a GET request and I have been specifying various parameters to filter what is being returned. The request URL is "/api.ashx/v2/activities.xml" with the attributes and values appended to the URL after a '?'. I have tried a number of attributes and they all work individually. The problem I have is that when I try to use more than 1 parameter with '&' between them, it appears that only the first parameter that I specify is seen and the rest are ignored. I get the feeling I am missing something really trivial. Any clue to what I am missing would be appreciated.

2 Replies

  • Can you attach a fiddler trace?

  • In reply to Patrick Mason:

    Well interestingly enough, to run fiddler on it I had to do some stuff I hadn't tried before and that led me to find that the problem was the CURL command I was using in my program. I didn't quote the URL and the & was being interpreted as a command line directive. When I quote the URL the & is part of the URL and everything starts working. I knew it had to be something simple. Thanks for giving me the kick I needed.