Issue installing Telligent Community 7.6


We're trying to install Telligent Community ver and we're getting the following error...  So far we just put the site on IIS 7 and windows 2008 R2 running framework 4.0 with recommended patch.

Server Error in '/' Application.

The requested page is not a part of the current theme.

 Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Telligent.Evolution.Components.CSException: The requested page is not a part of the current theme.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:

[CSException: The requested page is not a part of the current theme.]

  Telligent.Evolution.Controls.ContentFragmentPageBase.OnInit(EventArgs e) +1672

  System.Web.UI.Control.InitRecursive(Control namingContainer) +508

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

Any ideas on what's causing this?

Thank you

  • In reply to Luke D:

    Ok - I found your two XML files in the first .rar file...

    It does appear tha tif this is your default theme you are missing some pages in there...  I'm not entirely certain how to re-generate these...

    You might try edit the plugin versions for the Telligent Plugins, recycle the app pool and see if they get re-created..  Otherwise hopefully someone from Zimbra can chime in.  I believe if the plugin version in the Database differs from the DLL it will force the Install() method to be re-executed, and since this is a development instance, it might be worth a shot.

    SELECT TOP 1000 [Type]
      FROM [Community].[dbo].[te_Plugin_Versions]
  • In reply to Luke D:

    current version shows  I updated it in sql to and recycled the pool but it automatically updated it to correct version. :(  still same error on site.


  • In reply to rbaranov:

    Is there anything showing up in the cs_Exceptions table?

  • In reply to Luke D:

    yes 5 records...

    I attached them to this reply.
  • In reply to rbaranov:

    So It does appear the file installation plugin is throwing an exception...not sure why...

  • In reply to Luke D:

    Are you sure that the folder is indeed readable and writable by the user running the AppPool?

  • In reply to Luke D:

    I'll paste it in here incase anyone from Zimbra looks at it:

    An error occurred while loading the plugin: Telligent.Evolution.Components.FileInstallationPlugin

    System.Web.HttpException (0x80004005): Response is not available in this context. at System.Web.Util.HttpEncoder.get_Current() at Telligent.Evolution.Components.UrlManipulation.ParseQueryString(String queryString) at Telligent.Evolution.Controls.GroupSelectionList.AdjustAfterSerialization(ConfigurationDataBase data, Property property, String value) at Telligent.Evolution.Extensibility.UI.Version1.ConfigurableContentFragmentBase.SerializePropertyData(Boolean forExport) at Telligent.Evolution.Components.ContentFragmentPageService.›(ConfiguredContentFragment fragment, XmlTextWriter xw, Boolean isExporting) at Telligent.Evolution.Components.ContentFragmentPageService.š(IList`1 fragments, XmlTextWriter xw, Boolean isExporting) at Telligent.Evolution.Components.ContentFragmentPageService.SerializePage(ContentFragmentPage page, Guid themeType, XmlTextWriter xw, Boolean isExporting) at Telligent.Evolution.Components.ContentFragmentPageService.SaveFactoryDefaults(Theme theme, XmlNode node, Boolean fromExport, Nullable`1 deserializeContentFragments) at Telligent.Evolution.Components.ThemeConfigurations.DeserializeTheme(XmlNode node, Boolean fromExport, Boolean deserializeContentFragments) at Telligent.Evolution.Components.FileInstallationPlugin.„ƒ() at Telligent.Evolution.Components.FileInstallationPlugin.Install(Version lastInstalledVersion) at Telligent.Evolution.Components.PluginManager.‰()
  • In reply to Luke D:

    Do you have the URL rewrite module installed in IIS?

  • In reply to Luke D:

    hi, yes permissions are based on the app pool and filestorage has full access.  While root of app its just read.

    for url rewrite, yes rewrite module 2.0 is installed.  Not sure if it needs to be enabled or something.

  • In reply to rbaranov:

    For the heck of it, can you try the following:

    1. Rename current filestorage to "filestorage_bak"
    2. Copy the filestorage from the zip to the same location in your website directory (I think it only contains a web.config)
    3. grant "Full Control" to "Everyone" on the new filestorage folder and apply permissions to everything in the directory
    4. Update the plugin versions like we did earlier
    5. recycle the app pool
    6. do an iisreset
    7. try hit your homepage.

    If that doesn't work I am all out of ideas and would probably need to mess with it locally.

  • In reply to Luke D:

    :), so it kind of worked.

    besides the above steps you mentioned in previous post, I also applied the hotfix which didn't help and threw same message after recycling pool.

    But then I did your steps above and it kind of worked.

    So version on database reverted back from to which I think is right.

    And site loads a bit.  I see the Telligent favicon come up and I see their grey background.  But there is nothing else on the page.  

    /controlpanel or /login.aspx show same grey screen as the homepage.

  • In reply to rbaranov:

    or is that it pretty much for first step and the rest of the site will show up after setting up solr and jobs?

  • In reply to rbaranov:

    No, your site should pretty much load-up and be functional

  • In reply to Luke D:

    I'd check for new exceptions in the exception table

  • In reply to Luke D:

    yea, I truncated that table before, so its empty now and not getting filled in.  Event viewer is also empty.  

    hm. with the rewrite module on iis7, is it just installing that rewrite module from here and that's it?