Issue installing Telligent Community 7.6


We're trying to install Telligent Community ver and we're getting the following error...  So far we just put the site on IIS 7 and windows 2008 R2 running framework 4.0 with recommended patch.

Server Error in '/' Application.

The requested page is not a part of the current theme.

 Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: Telligent.Evolution.Components.CSException: The requested page is not a part of the current theme.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace:

[CSException: The requested page is not a part of the current theme.]

  Telligent.Evolution.Controls.ContentFragmentPageBase.OnInit(EventArgs e) +1672

  System.Web.UI.Control.InitRecursive(Control namingContainer) +508

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

  System.Web.UI.Control.InitRecursive(Control namingContainer) +250

Any ideas on what's causing this?

Thank you

  • In reply to rbaranov:

    have you considered starting over from scratch :)

  • In reply to Luke D:

    we've done that. :) few times.  the server is our vm, so we just restore the clone and tried again few times.  

    There is just not that many steps to get wrong.  

    Only thing im thinking is either initial install file we downloaded from Telligent is corrupt, or there is something missing on the server level that's causing this.  

  • In reply to Luke D:

    are you running your app pool in integrated mode and .NET 4?

  • In reply to Luke D:

    Final Thought:

    When you downloaded the zip file - did you right-click it and select "Unblock" before deploying the website files??

  • In reply to Luke D:

    Yes app pool is in integrated mode with 4.0. I do not have that option to unblock.

  • In reply to rbaranov:

    hi Roman,

    Could you write down the exact steps you performed when creating the test site.



  • In reply to rbaranov:

    Hi Roman,

    I'm not sure you are or at least there is something different about what you are doing.  Please write down exactly what you are doing and we may be able to figure out what is wrong between us all.



  • In reply to Robert Nash:

    Create a path to Telligent Community website (C:\Telligent).

    From zip file (, we copied contents of WEB folder to C:\Telligent

    Added to application pool “Telligent Evolution” / integrated / .NET v4.0.30319

    Add website “Telligent Evolution” point to previously created application pool and point physical path to C:\Telligent

    Edit permissions for Telligent Evolution website to allow IIS APPPOOL/Telligent Evolution Read permissions.

    Edit permissions for filestorage folder to allow IIS APPPOOL/Telligent Evolution Modify, Read & execute, List folder contents, and Write permissions.

    Create database on SQL server “TelligentEvo1”

    Run cs_CreateFullDatabase.sql query against “telligentEvo1” DB

    Create community by running the following query against “TelligentEvo1” DB:


       @SiteUrl = N''

     , @ApplicationName = N'Telligent Evolution'

     , @AdminEmail = N''

     , @AdminUserName = N'admin'

     , @AdminPassword = N'pa$$word'

     , @PasswordFormat = 0

     , @CreateSamples = 0

    Create SQL account “telligentevo1”

    Give following permissions to “telligentevo1” account on “telligentEvo1” DB:

    • aspnet_Membership_FullAccess

    • aspnet_Profile_FullAccess

    • db_datareader

    • db_datawriter

    • db_ddladmin

    Update connectionstrings.config file:

    <?xml version="1.0" encoding="utf-8"?>


     <add name="SiteSqlServer" connectionString="server=;uid=telligentevo1;pwd=XXXX;Trusted_Connection=no;database=TelligentEvo1" />


    After these steps we should be able to see default page as per the documentation. We were getting the error mentioned in the original post but since working with Luke just now get a blank grey screen but do see the Telligent icon in the URL bar.

  • In reply to rbaranov:

    hello, any help or ideas on what to do or try next?  thank you

  • In reply to rbaranov:

    Forgive my jumping in with a few questions. But since you asked for any ideas -

    Can you look line-by-line through the install procedure and ensure that you verified success at each step?

    You stated you performed a fresh install multiple times. Did you start using the same (as you noted, unblocked) package from scratch each time into an empty folder, or into the same folder and perhaps not overwrite previous folder contents?

    Is it possible IIS is pointing to a previous/different installation's web folder?

    Did you assign all of the stated database permissions to the system user when you created the schema?

  • In reply to Jenny Jarrard:

    Hi Jenny,

    Np, any help is appreciated.

    We've done install before in our dev environment on older iis 6 versions with success, but this time its on a fresh vm box and iis7.

    Yes looked over the step by step instructions that telligent provides.  Its pretty clear from them on the process.  We basically get stuck at the place when they ask you to verify that you're site is up before proceeding to installing SOLR and job scheduler.  

    Yes when we did reinstalls, it was into a brand new folder with nothing  in there.  

    No, we checked IIS to make sure its pointing to correct place.  

    Yes, we tried users on database with permissions specified in the document as well as db_owner rights.  

    I don't think thats the issue as it was writing event logs into the exception table.  


  • In reply to rbaranov:

    The last thing Jenny wanted you to verify was if you right-click your zip file to ensure it is "Unblocked"

  • In reply to Luke D:

    Hi Roman,

    Let's try to work backwards to see what the issue could be, the original problem was that it could not find the theme files.  This can be caused by (from my experience)

    1) the theme files are missing

    2) file permissions to the filestore is wrong

    3) filestore paths wrong in CommunityServer.config or CommunityServer_override.config

    4) the default theme not existing

    5) the theme information missing from the database te_themes table

    6) a clean unzipped website is connected to a database that has been used at least once before

    Now you have the page layouts working but the widgets are not displaying, this usually (again from experience) means a global issue that is causing every widget to throw an exception, so I would check:

    1) the exceptions table

    2) the event logs table

    3) the te_plugins table to check there are no custom plugins enabled

    If none of that shed's any light then I'm sure someone at Zimbra support will be able to help you through the process.



  • In reply to Robert Nash:

    We must have had a corrupt zip file for initial installation. Downloaded everything fresh and went through the steps again. I am happy to report the default page is now loading. I want to thank everybody who contributed to the thread and assisted in troubleshooting.