• API Issues

    We are experiencing some issues with the API, and I can't determine what the cause is. We are running version 5.5, I have enabled the REST API in the Control Panel, and I have created a new API Key. When logged in, I can access the old API through...
  • Importing avatar image via REST API clear profile felds

    Hi, It might look strange but now I'm 100% sure that it happens. I'm importing users and their avatar images via REST API. First user is imported using add web service (http://telligent.com/community/developers/w/wiki/add-user.aspx), id...
  • REST API v2 Authentication with Flash

    We are trying to access the REST API v2 from Flash Player and have been unable to connect. Our Community site sits behind windows authentication and we've been trying to use the Authorization Cookie as explained in http://telligent.com/community/developers...
  • Can we search users by firstname, lastname using REST API

    Hi, We are on Telligent community 5.5. We are using REST API for few functionality. is there REST API support for searching users by firstname, lastname etc. I know in Telligent REST API update 5.5.2 there is support find users by email address. ...
  • Creating REST CustomEndpoints

  • Re: API and user status messages

    Hi Charles, You need to use the V2 REST API endpoint (TC5.0 > only). The endpoint you want is: api.ashx/v2/users/{username}/statuses.xml more info can be found here: http://telligent.com/community/developers/w/wiki/get-status-messages.aspx...
  • Latest API Documentation

  • Problem to access API .

  • REST debug console is not available when we updated REST SDK 5.5.2

  • Cannot load REST API on base install

    When I try hitting api.ashx/v2/!console on our base install, I get resource not found. Is there something I'm missing from the setup? Thanks! -Auri
  • How To retrieve Users in Role?

  • IEventService.GetEvents - tag filters seem to be caching results

    We have a custom endpoint that wraps the IEventService and calls into "GetEvents", which is the 4th overload to this method, accepting calendarId, filterTags, logicallyOrTags, pageSize, pageIndex. When integration testing this via the REST...
  • RE: How to get or reset user's password using REST API

    We highly recommend that you use the functionality that ships with the product to handle password resets. That being said, you can change passwords via REST, by POSTing a user update with OldPassword/NewPassword. You could write some code to generate...
  • TC 5.0 Wiki API?

    I see here: http://telligent.com/community/developers/w/wiki/wiki.aspx , that the wiki API is not added until version 5.5. This is unfortunate as I am currently needing that in 5.0. Has anyone else had this issue? If so is there a work around that you...
  • Adding a user to a private group using REST API v2 (Telligent Community 5.6)

  • Why would "Recent" threads look at db entry date and NOT post date

    We are doing a major import from vBulletin with help from a vendor and they said that all the "recent" lists for posts in forums are going to be filled with the migrated content rather until the community has new activity. They are using the...
  • "Deleted" CalendarEvent is still pulled from EventQuery (TC6)

    We wrote our own REST endpoints for querying calendar events for TC6.0. It appears that when users set up events in the Telligent site and then delete them, our rest endpoint still pulls them. However, if I query the endpoint directly in the REST console...
  • REST API Add User - Internal Server Error?

    I'm trying to create a user programattically via the REST API (Telligent Community 5.5). I've followed the user creation sample from http://telligent.com/community/developers/w/wiki/add-user.aspx replacing the site/user specific bits of course...
  • The caller was not authenticated by the service.

  • Marks conversation as read with REST API

  • Error when creating user via REST API

    The user gets created in the Telligent Community, but the error message indicates there was an auxiliary function that did not happen properly, which in turn, doesn't send back a 200 (OK) status code. After using the v2 debug console, the problem...
  • Help needed: "A new top-level group cannot be created."

    Hi gurus I am trying to add a new group through the API but get the subj. error message. I have tried adding the group using the groupsService, the siteService and just by calling group.Add(); All in vain :-( This is my code: public...